Articles in this section

My vacuum doesn't clean every room, skips areas.

Problem

Wyze Robot Vacuum does not clean every area during a run, and skips one or more rooms. 

Possible Causes:

  • The vacuum was manually moved during the first mapping / cleaning.
  • Wyze Robot Vacuum was unable to complete the first clean on its first battery charge, which can cause issues during the next session.
  • There were obstacles blocking off an area / room during the first mapping / cleaning. 

Troubleshooting Tips:

  • Do not interrupt or move the vacuum during a clean. 
  • Make sure paths to each room in an area are clear of obstacles.
  • Reset the map, then start a "Clean" with the vacuum starting at the charging station and returning to the charging station with no interruptions during the clean.

Contact Us

  • Service Status

    Check if there are any ongoing issues on wyze.com & the Wyze app.

  • Live Support Hours:

    Monday through Friday, 6AM-6PM, Saturday & Sunday 8AM-4PM Pacific. Holiday hours may vary.

  • Join our Community

    Find answers, ask questions, and connect with your fellow community of Wyze users.